WIDEX BEYOND™ APP COMPATIBILITY

Apple devices 
  • iPhone 5S
  • iPhone 6
  • iPhone 6 Plus
  • iPhone 6S
  • iPhone 6S Plus
  • iPhone 7
  • iPhone 7 Plus
  • iPhone 8
  • iPhone 8 Plus
  • iPhone SE (see note)
  • iPhone X
  • iPad Air
  • iPad Air 2
  • iPad mini 2
  • iPad mini 3
  • iPad (4th generation)
  • iPad mini with Retina display
  • iPod touch 6th generation
  • Apple Watch Series 1 & 2
Android devices
  • Samsung A5 (2017)
  • Samsung Galaxy S6
  • Samsung Galaxy S6 Edge
  • Samsung Galaxy S7
  • Samsung Galaxy S7 Edge
  • Samsung Galaxy S8
  • Samsung Galaxy S8+
  • Samsung Galaxy Note 4
  • Samsung Galaxy Note 5
  • Samsung Galaxy J5 (2017)
  • HTC 10
  • LG G5
  • LG Nexus 5X
  • Sony Xperia XZ
  • Motorola Moto Z Play
  • Motorola Moto G5
  • Motorola Moto X Force
  • Google Pixel
  • Google Pixel XL
Compatible systems requirement
  • Apple: iOS 10.x and 11.x (see note)
  • Apple Watch: watchOS 3 and 4
  • Android: OS version 6.0.1 or later

The BEYOND™ app solution is designed and tested with the above mentioned devices and operating systems.

If your Apple or Android device is not mentioned in the supported device list/ or has a non-supported operating system, the functionality of the app is not guaranteed. Please contact your hearing care professional for advice.

Note: 
Widex cannot confirm optimal compatibility with iOS 11.4, specifically for iPhone SE. We recommend users not upgrading to iOS11.4 at this time.

Contact Us

Got a question or comment for us?
Contact us

Local Widex websites

Widex A/S

Nymøllevej 6

3540 Lynge

Denmark