WIDEX EVOKE™ APP COMPATIBILITY

Apple devices
  • iPhone XS Max
  • iPhone XS
  • iPhone XR
  • iPhone X
  • iPhone 8 Plus
  • iPhone 8
  • iPhone 7 Plus
  • iPhone 7
  • iPhone 6s Plus
  • iPhone 6s
  • iPhone 6 Plus
  • iPhone 6
  • iPhone 5S
  • iPhone SE

  • Apple Watch Series 1, 2, 3 (none-LTE), 4
    Notice that iPhone connection to Apple Watch is required.

  • iPad (5th generation)
  • iPad mini (4th and 5th generation)
  • iPad Pro 11"
  • iPad Pro 12.9"
  • iPad Pro 10.5"
  • iPad Air 3
  • iPad Air 2

Android devices
  • Samsung Galaxy S10+
  • Samsung Galaxy S10
  • Samsung Galaxy S9+
  • Samsung Galaxy S9
  • Samsung Galaxy S8+
  • Samsung Galaxy S8
  • Samsung Galaxy S7
  • Samsung Galaxy S7 Edge
  • Samsung Galaxy A5 (2017)
  • Samsung Galaxy Note 8

  • Huawei Nexus 6P
  • Google Pixel 3
  • Google Pixel 3 XL
  • Google Pixel 2
  • Google Pixel 2 XL
  • Google Pixel
  • Google Pixel XL
  • LG G6
  • One Plus 6T
  • HTC 10
  • Motorola Moto G5
  • Sony Xperia XZ
  • Sony Xperia XZ Premium
  • Xiaomi Redmi 6
Compatible systems requirement
  • Apple: iOS 11.x and 12.x
  • (11.4.0 is not supported)
  • Apple Watch: watchOS 4.3.2 and 5.3
  • Android: OS version 7.0, 8.0, 8.1, 9.0
The EVOKE™ app solution is designed and tested with the above mentioned devices and operating systems.

If your Apple or Android device is not mentioned in the supported device list/ or has a non-supported operating system, the functionality of the app is not guaranteed. Please contact your hearing care professional for advice.

Contact Us

Got a question or comment for us?
Contact us

Choose Country/Region

Widex A/S

Nymøllevej 6

3540 Lynge

Denmark